Дано: компьютер с установленным дистрибутивом ArchLinux (2010.05) с графической средой (KDE\Gnome или любой другой).
Задача: установить средство виртуализации для опробования различного рода Windows\Linux дистрибутивов без вмешательства в основную систему.
Решение:
Если не предъявляется серьёзных требований к быстродействию виртуальной машины, в качестве простого и удобного средства виртуализации можно применить VirtualBox от компании Oracle (ранее SunMicrosystems).
В репозиториях ArchLinux существует 2 пакета VirtualBox:
Предполагается, что в операционной системе настроены зеркала репозиториев. Для установки, от имени root`а нужно ввести:
# pacman -S virtualbox
Если нужен графический интерфейс, доустанавливаем qt
# pacman -S qt
Теперь необходимо добавить пользователя (от имени которого будет запускаться машина) в группу vboxusers.
# gpasswd -a имя_пользователя vboxusers
, где "имя_пользователя" - логин зарегистрированного в системе пользователя. Для вступления изменений в силу, необходимо чтобы указанный пользователь вышел из системы и снова зашёл. Если не добавить пользователя (пользователей) в группу vboxusers, то у текущего пользователя не получится расшарить usb-устройства в виртуальную машину.
Далее собираем модули, необходимые для функционирования Virtualbox:
# /etc/rc.d/vboxdrv setup
ВАЖНО! При каждой смене ядра или его перекомпиляции, необходимо повторно собирать модули этой командой.
Теперь указываем системе, чтобы она загружала модули автоматически при старте. Редактируем файл /etc/rc.conf и ищем строку c параметром MODULES и к списку модулей в скобках, добавляем имена модулей через пробел: vboxdrv vboxnetflt vboxnetadp .
# MOD_AUTOLOAD="yes" #MOD_BLACKLIST=() #deprecated MODULES=()
Редактируем её до такого вида:
# MOD_AUTOLOAD="yes" #MOD_BLACKLIST=() #deprecated MODULES=(vboxdrv vboxnetflt vboxnetadp)
Модули подгрузятся автоматически после перезагрузки, а пока можно загрузить модули вручную:
# modprobe vboxdrv # modprobe vboxnetflt # modprobe vboxnetadp
Если не собрать модули и не загрузить их, при запуске любой виртуальной машины в среде VirtualBox, вылезет такая ошибка:
После установки можно приступить к первому запуску и настроке программы. Запустить VirtualBox можно из меню Gnome:
Applications → System Tools → Oracle VM VirtualBox
или командой:
$ virtualbox
Делается через меню программы: File → Preferences → Language . VirtualBox поддерживает большое количество языков и русский среди них.
Делается через меню программы: Файл → Настройка → Общие . По умолчанию он расположен в домашней директории, но будет лучше, если пользователь выделит под виртуальные машины отдельный диск или раздел. Размер раздела зависит от количества машин. Для задачи "просто попробовать" много дистрибутивов, нужно исходить из расчёта 10Гб на одну машину.